Flux v2.7.0
+++++~~~~~~~~~~~~~*
Changes
- Source-controller v1.7.0changed
- Kustomize-controller v1.7.0changed
- Notification-controller v1.7.0 v1.7.1changed
- Helm-controller v1.4.0changed
- Image-reflector-controller v1.0.0 v1.0.1changed
- Image-automation-controller v1.0.0 v1.0.1changed
- Source-watcher v2.0.0 v2.0.1changed
- Add backport label for v2.6.xchanged
- Update image-reflector-controller to v0.35.1changed
- Add digest pinning to image automation testingchanged
- Correct small typochanged
- Remove credentials sync manifestschanged
63 more lines
- Add sparse checkout to clichanged
- Fix knownhosts key mismatch regression bugchanged
- Make service-account name configurable in flux create tenantchanged
- Update toolkit componentschanged
- Promote image CLI commands to stablechanged
- Update toolkit componentschanged
- Bump pkg/ssa to v0.49.0 for CABundle validation fixchanged
- [RFC-0010] Add workload identity support for remote clusterschanged
- Update toolkit componentschanged
- Fix flux push artifact for insecure registrieschanged
- [RFC-0010] Add workload identity support for remote generic clusterschanged
- Fix flux diff kustomization ignore patternschanged
- Upgrade fluxcd/pkg dependencieschanged
- Manifests: Add app.kubernetes.io/part-of: flux label to controller podschanged
- Migrate sourcesecret package to runtime/secrets APIschanged
- Implement flux migrate commandchanged
- [RFC-0007] Implementation history updatechanged
- Run conformance tests for Kubernetes 1.34.0changed
- Update to Kubernetes v1.34.0 and Go 1.25.0changed
- Allow the Go runtime to dynamically set GOMAXPROCSchanged
- [RFC-0011] OpenTelemetry Tracingchanged
- [RFC-0012] External Artifact APIchanged
- Add --show-history flag to debug helmreleasechanged
- Skip release candidates on updateschanged
- Update image-reflector-controller to v1.0.0changed
- Update source-controller to v1.7.0changed
- Add the source-watcher controller to the Flux distributionchanged
- Add read-only commands for ArtifactGenerator kindchanged
- Update image-automation-controller to v1.0.0changed
- Update image-reflector-controller to v1.0.1changed
- Implement flux [reconcile|suspend|resume] image policy commandschanged
- Handle force: enabled annotation in flux diff ks commandchanged
- Remove ArtifactGenerators during uninstallchanged
- Add support for ExternalArtifact to flux tracechanged
- Set Kubernetes 1.32 as min supported versionchanged
- Add support for custom storage namespace in HelmRelease creationchanged
- Update toolkit componentschanged
- Update source-watcher to v2.0.1changed
- Add --show-history flag to debug kustomizationchanged
- Update image-automation-controller to v1.0.1changed
- Fluxcd/flux2/action: Determine latest version without using GitHub APIchanged
- General availability release of the Image Automation APIs (ImagePolicy, ImageRepository, ImageUpdateAutomation)added
- Watch for changes in ConfigMaps and Secrets references (Kustomization, HelmRelease)added
- Support for remote cluster authentication using Workload Identity (Kustomization, HelmRelease)added
- Extend the readiness evaluation of dependencies with CEL expressions (Kustomization, HelmRelease)added
- Support for global SOPS Age decryption keys on single-tenant clusters (Kustomization)added
- Support for optional Kustomize components (Kustomization)added
- Introduce RetryOnFailure lifecycle management strategy (HelmRelease)added
- Support mTLS for sending alerts to external systems (Provider)added
- Object-level workload identity authentication (Bucket, Provider)added
- Support mTLS for GitHub App transport (GitRepository, ImageUpdateAutomation, Provider)added
- OpenTelemetry tracing for Kustomization and HelmRelease reconciliation (Provider)added
- Support for 3rd-party source controllers (ExternalArtifact)added
- Support for source composition and decomposition patterns (ArtifactGenerator)added
- CancelHealthCheckOnNewRevision feature gate (kustomize-controller)added
- GitSparseCheckout feature gate (image-automation-controller)added
- ImageRepository v1 specificationadded
- ImagePolicy v1 specificationadded
- ImageUpdateAutomation v1 specificationadded
- ExternalArtifact v1 specificationadded
- ArtifactGenerator v1beta1 specificationadded
- Allow Azure CLI calls in flux push artifact --provider azure on DevOps runnersfixed
- Respect --all-namespaces flagfixed
11 maintenance lines (dependency bumps, CI, tests, docs)
- Use normalize.UnstructuredList instead of ssa.SetNativeKindsDefaultsmaintenance
- Cleanup GetArtifactRegistryCredentials error handlingmaintenance
- Update dependencies to Kubernetes 1.33.2maintenance
- Bump the ci group across 1 directory with 7 updatesmaintenance
- Use GITHUB_TOKEN for API calls in update workflowmaintenance
- Bump the ci group across 1 directory with 10 updatesmaintenance
- Align azure e2e tests secret names with fluxcd/pkgmaintenance
- Add source-watcher to the update workflowmaintenance
- Refactor CI with fluxcd/gha-workflowsmaintenance
- Bump the ci group with 6 updatesmaintenance
- Remove cron schedule from updatemaintenance
86 lines20 added53 changed2 fixed11 maintenancetyped from the source notes