platformchangelog.dev
43 tools
feedrelease

Flux v2.6.0

+++++++++++~~~~-***

Changes

  • Remove redundant space.removed
  • Source-controller v1.6.0changed
  • Kustomize-controller v1.6.0changed
  • Notification-controller v1.6.0changed
  • Helm-controller v1.3.0changed
  • Image-reflector-controller v0.35.0changed
  • Image-automation-controller v0.41.0changed
  • Use the default ephemeral GITHUB_TOKEN instead of the static onechanged
  • General availability release for the Flux OCI Artifacts APIs and flux artifact commandsadded
  • Support for OCI digests pinning (ImagePolicy, ImageUpdateAutomation)added
  • Object-level workload identity authentication (OCIRepository, ImageRepository, Kustomization, Alert Provider)added
  • Cache registry credentials for cloud providers (OCIRepository, ImageRepository)added
38 more lines
  • Git HTTP/S Mutual TLS authentication (GitRepository, ImageUpdateAutomation)added
  • Support for sparse checkout (GitRepository)added
  • Support for GitHub App authentication (Alert Provider)added
  • Support for managed Identity authentication to Azure Event Hub (Alert Provider)added
  • Customize the ID of the Git commit status with CEL expressions (Alert Provider)added
  • WaitForTermination deletion policy (Kustomization)added
  • DisableChartDigestTracking feature gate (HelmRelease)added
  • Add an annotation api.fluxcd.io/upgrade: "v2.6.0" to the OCIRepository resources. (this is not required if Flux Operator is used for upgrade)added
  • OCIRepository v1 specificationadded
  • AWS integrationsadded
  • Azure integrationsadded
  • GCP integrationsadded
  • OSSF scorecard configuration file - ignore false-positiveadded
  • Allow to pull/push artifacts to insecure registries without TLSadded
  • Add --interval and --reflect-digest flags to flux create image policyadded
  • Correct name on github app secretfixed
  • Fix command debug hr not taking targetPath into accountfixed
  • Allow recursive dry-run over local sourcesfixed
  • Fix exit code handling in get commandfixed
  • Fix flux trace for HRs from OCIRepository sfixed
  • Set apiVersion: source.toolkit.fluxcd.io/v1 in the YAML files that contain OCIRepository definitions.other
  • Commit, push, and reconcile the API version changes.other
  • Update RFC 0008 and RFC 0009 milestonesother
  • Update backport labels for 2.5other
  • [RFC-0010] Multi-Tenant Workload Identityother
  • Flux diff: Reset target struct before decodingother
  • Run conformance tests for Kubernetes 1.33.0other
  • [RFC-0010] Remove EKS Pod Identity from the proposalother
  • [RFC-0010] Add RBAC for creating service account tokensother
  • Upgrade fluxcd/pkg auth, oci, git and git/gogitother
  • [RFC-0010] Update RFC to include opt-in feature gateother
  • [RFC-0010] Update RFC feature gate behaviorother
  • Upgrade fluxcd/pkg packagesother
  • Upgrade fluxcd/pkg packagesother
  • Set Kubernetes 1.31 as min supported versionother
  • Update toolkit componentsother
  • Promote artifact commands to stableother
  • Update toolkit componentsother
9 maintenance lines (dependency bumps, CI, tests, docs)
  • Update kustomize-controller to v1.5.1maintenance
  • Switch to goreleaser changelog generationmaintenance
  • Bump helm.sh/helm/v3 from 3.17.0 to 3.17.3maintenance
  • Update to Kubernetes 1.33.0 and Go 1.24.0maintenance
  • Bump the ci group across 1 directory with 18 updatesmaintenance
  • Fix e2e workflowmaintenance
  • Update dependenciesmaintenance
  • Update CLI to OCIRepository v1 (GA)maintenance
  • Update dependabot configmaintenance
59 lines1 removed19 added7 changed5 fixed18 other9 maintenancetyped from the source notes

Full release notes ↗ · all Flux releases

Report a mistake

context

Tools

Flux

Other Flux releases

How this was written

The change list is the project's own release notes, sorted into change types by fixed rules. See the methodology.

Back to the feed